Rosetta Stone v3.4.7 Win/Mac with Audio + Update 24 Languages
Complete Colletion | 24 Languages | 47.32 GB

Here is an updated Rosetta Stone collection. I decided to upload this because most of the collections that I found are either missing some languages or have V2 files mixed in with the V3 files. I've edited list to make packs 1-2 because site wouldn't accept my torrent file. So I made two packs. The apps are included in each pack are the same. I just did it for convenience.

Arabic - 1, 2, 3
Chinese - 1, 2, 3
Dutch - 1, 2, 3
English(American) - 1, 2, 3, 4, 5
English(British) - 1, 2, 3
Filipinio(Tagalog) - 1, 2
French - 1, 2, 3, 4, 5
German - 1, 2, 3, 4, 5
Greek - 1, 2, 3
Hebrew - 1, 2
Hindi - 1, 2, 3
Irish - 1
Italian - 1, 2, 3
Japanese - 1, 2, 3
Korean - 1, 2, 3
Latin - 1, 2, 3
Persian(Farsi) - 1, 2, 3
Polish - 1, 2, 3
Portuguese(Brazil) - 1, 2, 3
Russian - 1, 2, 3
Spanish(Latin America) - 1, 2, 3, 4, 5
Spanish(Spain) - 1, 2, 3, 4, 5
Swedish - 1, 2, 3
Turkish - 1, 2, 3

All of these are ONLY v3.

uploaders notes about the app prismo wrote:
Since everyone seems to not know how to use pismo. Here is some instructions.

1.Install pismo.
2.Right click on the .iso file you wish to install and select "Mount".
3.Set "mount visiblity" to "entire system".
4.Set "everyone access" to "none".
5.Set "Formatter" to "auto".
6.Uncheck "open after mount".
7.Set map drive to a letter that is not in use by your system. Example "T:"
8.Click mount.
9.Add language in rosetta stone program.
10.Right click on .iso file and select umount when done.
I've also included what audio companions that i could find.

Only some have audio companions, not every lang. unfortunately.
A lot of people were able to get this to work, some have problems of course.

But, hey its free and also freeleech for your ratio, so good luck to you

Try these tips if you run into trouble:

after 100x times reinstalling rosetta and failing to install languages i found the problem. as dashbranaghan mentioned you have to restart. however you have to restart immediately after installing before mounting the language files or starting the program!!

if program isn't working after install, try rebooting system.
For Mac Users:
Run the installer, go to your /Applications folder, control-click the "Rosetta
Stone Version 3" bundle, select Show Package Contents > Contents > Resources and
replace the "" file with the one in the CRACK folder. You must be running
as administrator to do this (if you installed it in the default location.) Don't
be afraid to update your language pack.

Hey everyone I was having the same issue as many of you where I was unable to
open a language file in Rosetta Stone despite having a language disc image
mounted through alcohol 52%. I uninstalled Rosetta Stoned and I found out what my
problem was. I did not originally run the installer exe as an administrator.
Don't just double click the installer, right click it and run it as
administrator. That solved all of my problems. On 64 bit systems like mine also
make sure it is installed to the program files (x86).

Oh also turn off your WiFI and don't forget to UNCHECK "run after set up"

hey guys, i have had RS for about 6months now, and i get that 2126error every
now and then. Try it 3 times, if it wont open, restart your computer. It has
worked for me every time.
For the 2125 error from pirate bay:

I downloaded this thing and everything worked great the first day then the next
day it said Error 2125, database is outdated. I researched online and there were
lots of posts talking about a tracking.db3 file, but I had no tracking.db3 file.
So I deleted the updateinstaller.dll file and its worked fine ever since! Thanks!
Deleting the updateinstaller.dll works. The program runs from where it was like
nothing happened. Cheers!

for you guys having issues with Win 7/Vista:
you have to change installer compatibility to Win XP, here's how:
1)Right click Rosetta Stone installer progam (before you install, of course)
2)Click "Compatibility" tab
3) Check "Run this program in compatibility mode for:"
4) Change to Windows XP (Service Pack 3)
5) ???
6) Profit

For people with an installation problem with netsh.exe
Go to search and find "services"
Run it and make sure Windows Firewall is started. It does not have to be
automatic. Now it should install properly.
If you got a custom Firewall like me then you can go back into services and turn
Windows Firewall off once installation is done

Mac: Mac users just look at earlier comments. Download....right click on the
application icon and go to "show package contents", go to "resources", make a
copy of the cracked mdm.dat file and place it in the resources file, when it asks
if you want to replace say yes. A copy is especially important especially if you
want to keep seeding....Had to download part of torrent twice (short bus
member....yeah I know) Reopen program, may not respond right away, took me three
or four times, add the languages by launching the iso files and the program will
pick them up....I can report that arabic works.
Please read the above tips that I've included, these are from users that have already gone through some aggrevation with the install and loading of languages

Only the registered members can see the download links/content. please Register to gain full access.
Extabit = High Speed
Only the registered members can see the download links/content. please Register to gain full access.
Only the registered members can see the download links/content. please Register to gain full access.