+ Reply to Thread
Results 1 to 14 of 14

Thread: Suitcase on Mac X Helvetica Neue X Chrome issue

  1. #1
    Junior Member JayFlow will become famous soon enough JayFlow will become famous soon enough
    Join Date
    Feb 2013
    Location
    Rio de Janeiro, Brazil
    Posts
    30
    Thanks
    43
    Thanked 101 Times in 17 Posts

    Suitcase on Mac X Helvetica Neue X Chrome issue

    I've been having trouble when using my font manager (Suitcase, OSX) while on google Chrome. It displays Helvetica Neue like this:


    I've looked all over for a solution but couldn't find that actually solved it.
    here are some discussions on the topic:

    http://diarmaidcollins.wordpress.com/2012/05/19/helvetica-neue-and-chrome-not-a-very-satisying-mix/

    http://superuser.com/questions/521363/helvetica-neue-font-error-boxed-characters-on-google-chrome-for-mac

    They all come to the conclusion that this is a conflict between Chrome and Suitcase.
    Well, that is a problem for me, as I'm a web designer and kind of have got to have both of them running side by side most of the time and Helvetica IS widely used on the web.

    Does anybody experience any similar behavior with their font management? Have you come to any solutions?

    Thanks in advance!

    p.s.: I really hope to not need giving up Suitcase altogether, as I've got my stuff so neatly organized by now...

  2. The Following User Says Thank You to JayFlow For This Useful Post:

  3. #2
    Member wordnerd has much to be proud of wordnerd has much to be proud of wordnerd has much to be proud of wordnerd has much to be proud of wordnerd has much to be proud of wordnerd has much to be proud of wordnerd has much to be proud of wordnerd has much to be proud of
    Join Date
    Jul 2013
    Posts
    185
    Thanks
    5,691
    Thanked 1,004 Times in 163 Posts
    JayFlow,

    Do you have another version of Helvetica Neue on your Mac besides the OS X system font?

    http://www.jklstudios.com/misc/osxfonts.html#controllinghelvetica

  4. The Following 2 Users Say Thank You to wordnerd For This Useful Post:

  5. #3
    Junior Member JayFlow will become famous soon enough JayFlow will become famous soon enough
    Join Date
    Feb 2013
    Location
    Rio de Janeiro, Brazil
    Posts
    30
    Thanks
    43
    Thanked 101 Times in 17 Posts
    Quote Originally Posted by wordnerd View Post
    JayFlow,

    Do you have another version of Helvetica Neue on your Mac besides the OS X system font?

    http://www.jklstudios.com/misc/osxfonts.html#controllinghelvetica

    Great post. I can't find specific folder he refers to on the walkthrough, though. I'll try searching around for it and let you know if it works.

    Thanks

  6. The Following User Says Thank You to JayFlow For This Useful Post:

  7. #4
    Junior Member JayFlow will become famous soon enough JayFlow will become famous soon enough
    Join Date
    Feb 2013
    Location
    Rio de Janeiro, Brazil
    Posts
    30
    Thanks
    43
    Thanked 101 Times in 17 Posts
    Didn't do the trick. Even after removing the files from the folder and replacing them in suitcase, everytime both programs are running side by side (with Helvetica Neue activated OR inactive), it keeps returning those boxed characters...

  8. The Following User Says Thank You to JayFlow For This Useful Post:

  9. #5
    Banned slimetec is on a distinguished road
    Join Date
    Sep 2013
    Posts
    21
    Thanks
    20
    Thanked 5 Times in 4 Posts
    I had a helvetica/chrome related problem once before (I don't use suitcase though), and had to switch over to a different version (ie not the system installed version) of the font in order to fix my problems.

    A few months later, a similar thing happened on my work mac. This time, (As mentioned in the superuser thread), removing the HelveticaCY.dfont did the trick.

    And yet another time, a co-worker of mine had to remove all H.N fonts, delete all instances of Chrome (including dev builds such as Canary or Chromium), reboot & rebuild font caches, and then she added the Helveticas back, and this did the trick.

    It's an extremely odd problem, hopefully one of these things helps you out.

  10. The Following User Says Thank You to slimetec For This Useful Post:

  11. #6
    Member theraabbot will become famous soon enough theraabbot will become famous soon enough
    Join Date
    Sep 2013
    Posts
    85
    Thanks
    1,633
    Thanked 105 Times in 38 Posts

    Same problem for me!

    I have this all the time when using my font management software, have to quit font explorer and restart chrome to fix it.

    This seems to be a common issue, anyone approached the chrome developers about this?

  12. The Following User Says Thank You to theraabbot For This Useful Post:

  13. #7
    Junior Member jrclose is on a distinguished road
    Join Date
    Nov 2013
    Posts
    25
    Thanks
    50
    Thanked 22 Times in 20 Posts
    I was having the same issue for the longest time; however, I found when I upgraded to Suitcase Fusion 5 and cleared my font cache it resolved it completely... so it could be dependant on what version of SF you're using.

  14. The Following User Says Thank You to jrclose For This Useful Post:

  15. #8
    Member theraabbot will become famous soon enough theraabbot will become famous soon enough
    Join Date
    Sep 2013
    Posts
    85
    Thanks
    1,633
    Thanked 105 Times in 38 Posts
    I'm gonna try onyx to clear out font cache, let's see if it works....

  16. The Following User Says Thank You to theraabbot For This Useful Post:

  17. #9
    Member wordnerd has much to be proud of wordnerd has much to be proud of wordnerd has much to be proud of wordnerd has much to be proud of wordnerd has much to be proud of wordnerd has much to be proud of wordnerd has much to be proud of wordnerd has much to be proud of
    Join Date
    Jul 2013
    Posts
    185
    Thanks
    5,691
    Thanked 1,004 Times in 163 Posts
    Font Finagler (shareware) and FontNuke (free) are good for clearing font caches as well.

  18. The Following User Says Thank You to wordnerd For This Useful Post:

  19. #10
    Member theraabbot will become famous soon enough theraabbot will become famous soon enough
    Join Date
    Sep 2013
    Posts
    85
    Thanks
    1,633
    Thanked 105 Times in 38 Posts
    I tried onyx - it seems to have worked! :)

  20. Your ad here

  21. The Following User Says Thank You to theraabbot For This Useful Post:

  22. #11
    Junior Member limakus is on a distinguished road
    Join Date
    Nov 2013
    Posts
    18
    Thanks
    3
    Thanked 7 Times in 7 Posts
    i tryed Onyx. works good

  23. The Following User Says Thank You to limakus For This Useful Post:

  24. #12
    Banned theupside is on a distinguished road
    Join Date
    Nov 2013
    Posts
    29
    Thanks
    20
    Thanked 11 Times in 11 Posts
    onyx works well.

  25. The Following User Says Thank You to theupside For This Useful Post:

  26. #13
    Member willlnyc is a jewel in the rough willlnyc is a jewel in the rough willlnyc is a jewel in the rough
    Join Date
    Jul 2013
    Posts
    63
    Thanks
    1,464
    Thanked 287 Times in 71 Posts
    Quote Originally Posted by theraabbot View Post
    I tried onyx - it seems to have worked! :)
    I had the same issues with both Safari and Chrome. Onyx solved both! YAY!

    Thanks for the suggestion!

  27. The Following User Says Thank You to willlnyc For This Useful Post:

  28. #14
    Banned uuuacyee is on a distinguished road
    Join Date
    Sep 2013
    Posts
    42
    Thanks
    3
    Thanked 1 Time in 1 Post
    this happend to me when i was trying to install INPUT font as system font in Mac OS

+ Reply to Thread

Similar Threads

  1. Replies: 0
    Last Post: 11-25-2011, 09:08 AM
  2. Linotype Helvetica Neue LT W1G
    By jerry in forum Resources
    Replies: 0
    Last Post: 08-22-2011, 11:56 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts