Would be grateful for a patch for this latest version.

Earlier patcher/license (8.4.2) don't work with 8.5.1.

TIA