I have a sm 102 with 1.02 modded with job card reader and a sm 52 with a 1.04, with PPI 4.5 and usb omnidrive i can write card for 1.04 but the same card isn't read from 1.02. Where is the problem? The language is different? How i can resolve the problem? Thanks a lot